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Introduction
System Requirements

MacChemtab 2.0 will (hopefully) run on any Apple Macintosh 
computer.  You must have System 6.0.x or System 7.0.x to run 
MacChemtab.  MacChemtab will work with black & white, 
monochrome, or color monitors, however if you want to use color in 
the graphing module you must be running System 7.

MacChemtab uses very little system memory, <128K to be 
exact.  The program should be run in a 256K memory partition 
because of some minor memory problems (see the README file).  The
program takes up slightly less than 100K of disk space, so it will fit on 
a System 6.0.5 System Disk and run on a Macintosh SE with 1MB of 
memory.  This makes MacChemtab an ideal program for the classroom
environment.

General Overview
MacChemtab is a database of the periodic table of the elements.

With MacChemtab, one can easily explore the relationships that exist 
between the elements in the periodic table.  By design, the database 
is easy to use.  It is, therefore, ideal for the educational environment.  
MacChemtab was designed for introductory high-school level 
chemistry courses as an add-on to the, “Introduction to the Periodic 
Table,” section.  It works well in the classroom environment to provide
students with:

• An introduction to databases on a computer.  It shows students how 
useful a computer is for storage and retrieval of complex 
information.

• An introduction to the periodic table by providing students with an 
easy, efficient way to retrieve sets of elements and display them in a 
list, a graph, or in the periodic table.

There are two general steps involved in using the database:

1: Define a set of elements by creating search parameters.



2: Display the elements using one of the predefined forms.

Section 3 of this manual describes how you can create, edit, and
delete search parameters to define a group of elements.  Section 4 
describes how you can view this information, and in some cases, 
manipulate it.



Viewing a Single Element
MacChemtab functions are accessed through the Macintosh 

Menu Bar.  One of the most basic functions of any database is to 
display information.  MacChemtab allows you to view all the 
information the database has to offer on each element.  To do this, 
select Single Element from the View menu and you will see a dialog 
box similar to figure 1.

Figure 1

On the left there are three radio buttons.  They are labeled 
Name, Number and Symbol.  If you know the atomic name, atomic 
number or atomic symbol of the element you wish to view, make sure 
the corresponding name, number or symbol radio box is checked.  
Next, type in a name, number, or symbol and it will appear in the text 
box on the right.  Click on the OK button to display the element, or 
cancel to cancel this operation and try something else.

You may enter the atomic name in any fashion, upper or 
lowercase.  The database converts the information you supply into a 
generic fashion to search for an element.  You may also type in part of 
the element’s name.  If, for example, you want to view the element 
Technetium, you may enter Technetium, TeChNeTiUm, TECH, tech, 
etc.  If you enter a name that applies to more than one element, you 
will receive an error message that tells you the name is ambiguous.  If
you see this error message, be more precise when typing in the name 
of the element.



When entering the atomic number, you must type in the exact 
number of the element you are looking for.  You cannot substitute 
words for numbers (i.e. forty-three instead of 43).

When entering the atomic symbol, you must type in the symbol 
exactly as it is defined in the periodic table.  As a rule, symbols with 
one character such as the symbol for Oxygen, ‘O,’ are uppercase.  If 
the symbol contains two or three letters, for example Unnilhexium or 
‘Unh,’ the first letter will be in uppercase and the rest in lowercase.  If
you enter valid information into the fields and click the OK button, you
will see a small window with all the element’s information in it.  That 
window looks similar to figure 2, which is an information window for 
Technetium.

Figure 2



Search Parameters
What is a Search Parameter?

A search parameter allows you to select a group of elements 
that meet certain criteria.  With a single search parameter, for 
example, you can find all the elements that have a melting 
temperature greater than 2000ºC.  If you create a parameter such as 
this one, you can filter out elements that you do not wish to study.  
Let’s create this search parameter so you can see what it will do for 
you.  To create a parameter, select New Search Parameter from the 
Select menu.  A dialog box will appear which is similar to figure 3.

Figure 3

The Atomic Number and = boxes are actually pop-up menus.  If 
you move the pointer to one of these boxes and hold down the mouse 
button, you can see all the searches available to you.  As you create 
the search parameter, read the text in the window from left to right.  
Currently the window can be read as, “Create Parameter in which 
Atomic Number is = Value.”  We want to change the window to say, 
“Melting Temperature is > 2000.”  First, use the left-most pop-up 
menu and select Melting Temperature.  Change the = in the middle 
pop-up menu to >.  Now, type in the value 2000.



You will notice that there are three buttons.  At this point, you 
can click on OK to create the search parameter.  Click on cancel to 
forget creating the search parameter so you do not change any 
information.  The Delete button is grayed out because you have not 
yet created this search parameter, so you cannot delete it yet.  After 
you click on the OK button, the database will find all the elements that
meet the search parameter.  After doing this, the Select menu will be 
updated and a new menu choice will be added.  The updated menu 
will look like figure 4.

Figure 4

The menu item shows you the search parameter, the number of 
elements that meet the search parameter, and a hot-key definition for 
the parameter.  The number of elements that meet the search 
parameter is displayed in brackets ( [12] ).  If you select the search 
parameter from the Select menu (or in this case hit CMD-Zero), you 
will see a window similar to figure 3, however it will be updated to 
show the parameter.  You can then edit the parameter and click on 
OK, or click on Delete to remove the parameter from the list.

You may create up to ten search parameters.  After you create 
each consecutive search parameter, the Select menu is updated with 
the new entry, however the number in brackets represents the 
number of elements that meet all the previous parameters, including 
the one you just created.

What is a Close-to Value?
One of the selections under the = pop-up menu in figure 3 is ~.  

This represents a close-to parameter.  By creating a close-to 
parameter, you find all the elements that are within a certain range 
from the value you specify.  For example, if you specify 10 as the value
and the close-to range is 3, you will find 7 through 13.  Creating a 



close-to value has the same effect as creating two different search 
parameters, one greater than the smallest value you are looking for 
and one less than the largest value.

How do I Change Close-to Values?



There are two points in the program from where you can change
the close-to values.  If you create a search parameter of the close-to 
type, you will see a number appear below the value you type in.  If you
click on that number, you can change that close-to value.  (That 
number is the close-to value for the characteristic in the left-most pop-
up menu.)  If you click on the number, you will see a dialog box similar
to the one in figure 5.  It is called the mini close value editor.

Figure 5

You can type in a new close-to value and click the OK button to 
change it, or click on the cancel button to leave the value alone.  You 
cannot save the close-to values to the disk with the mini close value 
editor.  To do this, you have to use the close value editor.  To open the 
close value editor, select Close Value Editor... from the File menu.  The
close value editor is shown in figure 6.

The close value editor allows you to see and change all the close
values at once.  First you will want to change all the close values to 
your liking.  The four buttons perform the following operations:

• Cancel will leave the close value editor without change the close-to 
values in memory or on disk.

• Revert will reset the close values on the screen to what they were 
when the program was first started.

• Temp will save the close-to values to memory, but not to disk.

• Save will save the close-to values to memory and to disk.

By saving close-to values to disk, you permanently change them.
Whenever you start MacChemtab those values are read into memory.  



By saving the close-to values to memory only, they are changed for the
current execution of the program.  Once you quit, they disappear.



Figure 6



Viewing Element Groups
After you create a few search parameters, you may want to 

display the elements that meet your search parameters in a couple 
different ways.  Each section below describes a different way to view 
this data.

The Element List
A list is one of the most common ways to view data.  The 

MacChemtab list window has a variety of features that enable you to 
manipulate the data so that you can see some patterns more clearly.  
If you select Selection List from the View menu, you will see a window
similar to the one in figure 7.  If the menu is grayed out, or not 
selectable, it is because you have not created any search parameters. 
Read section 3 of this manual to learn how to create search 
parameters.

Figure 7



There are five distinct sections to the list window:

• The scroll bar enables you to scroll through the list of elements.

• The size box in the lower right-hand corner allows you to resize the 
window.

• The bottom of the screen lists the search parameters that were in 
effect when this window was created.

• The middle of the screen is a list of elements.  By double-clicking on 
a list entry, you can pull up complete information about each listed 
element (see section 2, Viewing a Single Element).

• The top of the screen contains labels for each column.  You will 
notice that one of the labels is italicized.  This means the list you see
is sorted by this characteristic.  If you wish to change this, hold 
down the option key and click on the label you wish to sort by.  The 
right-most label is an arrow that points up or down.  This indicates 
that the sort is ascending or descending.  You can change this by 
holding down the option key and clicking on the arrow.  It will shift 
from up to down, or down to up and the list will update.  Below is a 
listing of the labels and what they stand for:

Name - Atomic Name Sym - Atomic Symbol
Z - Atomic Number Mass - Atomic Mass
V - Valence Electrons Melt - Melting Temperature
Boil - Boiling Temperature FIO - First Ionization Energy
Year - Year of Discovery ENG - Electronegativity
SPHT - Specific Heat Dens - Density
ARAD - Atomic Radius

The Periodic Table
Another good way to view patterns in the periodic table is to 

view the elements you have selected in the periodic table itself.  To 
pull up a graphic of the periodic table, select Periodic Table from the 
View menu.  This will create a window similar to the one in figure 8.



Figure 8

At the top of the window, your search parameters are listed.  
Each element that did not meet the search parameters is surrounded 
by a gray box.  You cannot do anything with these.  The elements that 
did meet your search parameters are surrounded with a black box.  
These are actually buttons that you can click in.  If you do, you will 
see complete information about that element (see section 2, Viewing a
Single Element).



Graphs
One of the best ways to see patterns is by using a graph.  

MacChemtab has a sophisticated graphing module built-in, and you 
can configure it to your liking.  Note that under System 6 you cannot 
create color graphs.

Changing the Graphing Options
You can change all the graphing options by selecting Set 

Graphing Options from the Graph menu.  You will see a dialog box 
similar to the one in figure 9.

Figure 9

A description of each option is below:

• Animate Graph Creation - You have the option to see the graph while
it is being created.  If this box is checked, you will see each graph 
point displayed one at a time.  If the box is not checked, 
MacChemtab will create the graph off-screen and copy it to the 
screen all at once.



• Use a Grid - You can have grid lines on the graph that extend across 
the graph from each label.  Grid lines will appear only if this is 
turned on.  If you are using System 7, you can change the color of 
the grid lines using the pop-up menu at the bottom of the dialog box.
The pop-up menu will be grayed-out until Use a Grid is checked.  
Note that if the grid lines are yellow or white, they will not show up 
when printed.

• Use hashmarks instead of dots - You can have each point on the 
graph represented by a dot or by hashmarks.  Dots will be displayed 
if this option is turned off.

• Use only elements which met the search parameters - If you wish, 
instead of using all the elements when creating a graph, you can use
the elements that meet the search parameters you create.  This way 
you can filter out any special elements from your graph.  This option 
is only available when you have created some search parameters.

• Connect the points - If this option is on, each point on the graph will 
be connected by a line.

• Limit the connection spacing to... - If this option is on, and the 
proper value is placed in the text-box, you can eliminate unnecessary
lines on the graph.  A good example of this option is to graph Atomic
Number on the X axis, Electronegativity on the Y axis, and limit the 
connection spacing to .6.  This will eliminate lines that would be 
drawn between elements on opposite sides of the periodic table.  
The result is the same as removing the vertical lines from a graph of 
y=tan(x) on a computer.  The computer cannot tell the difference 
from one end of the tangent line from the other, so it connects them. 
Since this line does not actually exist, it should be removed.  By 
removing unnecessary lines from a graph, you get rid of extra 
information that may distort your perception of a pattern.

• The pop-up menus at the bottom allow you to change the colors used
on different parts of the graph.  These are only available for users 
with System 7.

• Click on the OK button to accept the options.  There is no cancel 



button.



Creating a Graph
After you customize the graphing options as described above, 

you must set the characteristics that will lie on each axis of the graph.
To do this, select Graph from the Graph menu.  You will see a dialog 
box similar to the one in figure 10.

Figure 10

To choose the characteristic for each axis, use the pop-up 
menus.  At the bottom of the dialog box are two numbers labeled, X 
Axis Min and X Axis Max.  The values that appear in these boxes 
represent the maximum values for the elements you are going to 
graph.  In this example, you are going to graph all the elements with 
an atomic number between 1 and 109.  You can change these values 
by typing in new ones.  For example, if you only want to see elements 
past number 50, type 50 into the X Axis Min box.

Click Cancel to cancel this operation or click OK to create a 
graph.  The graph will look similar to the one in figure 11.



Figure 11

There are two things you can do with the graph window.  You 
can resize the window, and the Macintosh will shrink or expand the 
picture to fill up the entire window.  You can also click on any graph 
point to bring up complete information about that particular element 
(see section 2, Viewing a Single Element).



Window Operations
Open and Save

At some point you may want to save a window for later 
reference.  To do this, select Save As... from the File menu when the 
window you wish to save in the front-most window.  You will be 
prompted as to where you wish the saved file to go, and what name to 
give it.  MacChemtab uses the standard file dialog to do this, and it is 
something you should already be familiar with.  Figure 12 shows a 
Save File dialog box, and Figure 13 shows an Open File dialog box.

Figure 12

Figure 13



Close / Close All
You can close a window in one of three ways.  You can click on 

the close box for the window, which will make the window close.  You 
can select Close from the File menu to close the front-most window, or
you can select Close All from the File menu to close all of 
MacChemtab’s open windows.

Print
You can print any window MacChemtab creates, except for an 

element list window, by selecting Print from the File menu.  
MacChemtab uses the standard system printer driver that you are 
probably already familiar with.  You cannot print an element list 
window because that function has not yet been implemented into 
MacChemtab 2.0.  NOTE!  You can only print to a LaserWriter or 
StyleWriter  printer.  Printing is not available to ImageWriters as far 
as I know.. but you could try it..


